Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

javadoc: No public or protected classes found to document.

 
Ranch Hand
Posts: 81
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have 5 classes in my directory which is named "vss". Each of these classes is in the vss directory.
When I run the command:

All of the classes are documented except for one. When I try to run javadoc on just that class:


I get the error message:

This is the second time I've had this problem in the past two days, so I guess I need to figure it out instead of re-organizing my classes like I did the last time!
Here is the first portion of Session.java:
 
Ranch Hand
Posts: 3061
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's been a while since I ran javadoc by hand. More recently I have an ant build script that automates many such tasks for me. I suspect that you don't need the .java extension. Try removing it and see if that fixes your problem.
Layne
 
Everybody! Do the Funky Monkey! Like this tiny ad!
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic