posted 12 years ago
"Enumeration" was a lousy name and is found only on the "legacy" collections. "Iterator" is roughly the same thing with a more appropriate name. I'd never looked at ListIterator before, but it extends Iterator (so it "is" an Iterator) and adds backwards movement and a current position concept. Kool.