• Post Reply Bookmark Topic Watch Topic
  • New Topic

Help with EJB's  RSS feed

 
Johnny Kim
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have orion application server installed and I am looking at this website: http://www.orionserver.com/tutorials/ejbtutorial.html
to learn about EJB's. I have J2SE 1.4.2 installed and when I try to import the following, compiler won't recognize it...

import javax.ejb.*;
import java.rmi.RemoteException;

I believe I have to install J2EE api but I'm completely new to the field and I would appreciate if someone can give me detailed instructions on how to upgrade from J2SE to J2EE.

Basically, I'm trying to create a website using jsp's where user can register to become a member and sign in to gain access to certain features. I'm doing this only for practice purposes. I hope someone will help.. thanks in advance >.<
 
Marilyn de Queiroz
Sheriff
Posts: 9082
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, JohnnyNY Kim

Welcome to JavaRanch! Please adjust your display name to meet the JavaRanch Naming Policy, perhaps just drop the 'NY'.
You can change it here.

Thanks!

Now about your question:

Rather than an upgrade, J2EE is an add-on. EJB is definitely not Java beginner material, but this page will help you get set up with using j2ee stuff in orion.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!