Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

java 5.0 and Array Lists

 
Eric Grant
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using the current version of Java (5.0, or 1.5) and am trying to use an array list. I am getting an error saying that the source is not Java 5.0 and I need to use it, but I am using Java 5.0. Is there a setting I need to change? I never had any other version of Java on my computer.
Thank you for your time and effort.
 
marc weber
Sheriff
Posts: 11343
Java Mac Safari
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch!

It sounds like you're using an IDE. If so, which one are you using?

(In Eclipse 3.1 on the Mac, for example, there is a setting under Preferences / Java / Compiler to specify a Java version for "source compatability.")
 
Eric Grant
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for your help. I found the setting and it worked.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic