• Post Reply Bookmark Topic Watch Topic
  • New Topic

UnsupportedClassVersionError  RSS feed

 
Allen Bandela
Ranch Hand
Posts: 128
Eclipse IDE MS IE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why do I get this error?
Is it due to the JDK version?
I used JDK1.5. Is'nt Java backward compatible? It executed fine on my machine, but gave me the above error on a different machine. By the way, the exception occured while initializing an applet.
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24217
38
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you compile with JDK 1.5, by default, the class files will not work with older JDKs. Older class files will work with JDK 1.5. You can use the -target switch to generate code for older JVMs, but then you can't use any nw language features.

Moving to Java in General (Beginner).
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!