• Post Reply Bookmark Topic Watch Topic
  • New Topic

Package does not exist in NetBeans 5.0  RSS feed

 
Fred Arters
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi. This might belong in a different forum, but I am a beginner and this is probably a dumb beginner issue.. so here it is.

I am using NetBeans 5.0 and am getting a "package does not exists" compiler error on:

import org.hibernate.SessionFactory;
import org.hibernate.cfg.Configuration;

I have org.hibernate in a 'mypackages' folder and have imported the mypackages folder as a library. I have added the library to my project. I see it in the library list. This includes the packages under org and the classes under org.hibernate and org.hibernate.cfg.

When I type import and let NetBeans do code-completion it shows org. Then when I type org. it shows hibernate. It will even prompt me to add an import for org.hibernate.SessionFactory and do so if I allow it.

But once I try and compile the class it fails with a package org.hibernate does not exist.

I have searched thru these and other forums and can't find a soluiton. Any ideas?
 
Campbell Ritchie
Marshal
Posts: 55761
163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to the Ranch and sorry nobody has replied earlier.

Sorry I can't help any more, but I would suggest you ask a bartender to move this thread to the "Versions and IDEs" forum, and see whether they can help you. CR
 
Fred Arters
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks. I'll repost it there.
 
Fred Arters
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Unnecessary! I was adding the .java files and NetBeans is looking for compiled .class files either in a folder or a JAR. My bad.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!