Win a copy of The Journey To Enterprise Agility this week in the Agile and Other Processes forum! And see the welcome thread for 20% off.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

javac is not recognized?  RSS feed

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I followed Sun's "Hello World" tutorial for writing my first Java program.
I created the source file called HelloWorldApp.java in my C:\java directory. AT the command promptI entered C:\java and it took me to the right directory and I can see the file. However, when I enter the command: javac HelloWorldApp.java it does not create the class like the instructions say it should. Also, I get the following message after I enter this command at the prompt line that says... 'javac' is not recognized as an internal or extaernal command, operable batch file or external command.Can anyone point me to my problem. I think it it something simple in my setup?

Oh yes, I also added to the end of my already setup system path, a semicolon with the new path to the java bin directory that looks like this now:
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Java\jdk1.5.0_07\bin.
Thank-You.
 
Sheriff
Posts: 11343
Java Mac Safari
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Tom Matys:
...I also added to the end of my already setup system path, a semicolon with the new path to the java bin directory that looks like this now:
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\Java\jdk1.5.0_07\bin.
...


Does your PATH variable end in a period (as shown above)? If so, remove the period.

Did you close your Command Prompt after setting the PATH? If not, close it and re-open.
 
Tom Matys
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No period, but I needed to reopen the prompt screen. It worked.
Thank-You very much!
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!