• Post Reply Bookmark Topic Watch Topic
  • New Topic

set JAVA_HOME  RSS feed

 
Alessandro Ilardo
Ranch Hand
Posts: 218
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there,
on a Suse 10.1 I'm trying to run JBoss 4 which at the startup gives me the following message

run.sh: Missing file: /lib/tools.jar
run.sh: Unexpected results may occur. Make sure JAVA_HOME points to a JDK and not a JRE.


ok, then I checked where actually the jdk was
/opt/jdk1.5.0_07

from the console
echo $JAVA_HOME
/usr/lib/jvm/java


so, I tried to set the JAVA_HOME
export JAVA_HOME=/opt/jdk1.5.0_07
export PATH=$JAVA_HOME/bin:$PATH


just a quick check
which java
/opt/jdk1.5.0_07/bin/java
which javac
/opt/jdk1.5.0_07/bin/javac


fine.....I though
but as soon as log out and log in all the java enviroments back as were before.
What's going on? How can I solve my problem?
(how can I set that var for every user?)

Thanks in advance
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24217
38
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You have to edit the appropriate configuration files -- just setting the variables at the prompt affects your current session only.

I'm going to move this to our Linux/UNIX forum, where someone with a little more time than me will explain the details to you. In the meantime, you could try running "info bash" and reading the section on configuration files.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!