Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

UnsupportedClassVersionError

 
Mg Oo
Greenhorn
Posts: 22
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Java masters

How to escape such error? I face when I run files in other computers (eg.friends', lab's)
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This error occurs if the classes were compiled with a JDK that is newer than the one you're using to run them. Version 49.0 is the one generated by Java 1.5, so you're probably trying to run it with a Java 1.4 JVM.

Try compiling your code with the "-source 1.4 -target 1.4" options. This will only work if you use no Java 5-specific code, of course. If you do, upgrade the JVM on the other machine to Java 5.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic