• Post Reply Bookmark Topic Watch Topic
  • New Topic

VISTA Help  RSS feed

 
jide agboola
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
Im studying java and i had it installed on my machine. It had xp and i knew how to set the class path on that. But now i upgraded to vista and when i set the classpath its not working....i mean i cant run any java from the command line...how do i set the class path properly? what should i enter in the environment variable? can anyone tell me exactly what to enter and where to enter? I had just done it the way i did for my old XP, but not working still...
 
Campbell Ritchie
Marshal
Posts: 56578
172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you only set your CLASSPATH? You need to set your PATH too.

CLASSPATH should contain ;.; on Windows, and it is often set up properly before you start.
PATH should contain something like ;c:\Program Files\Java\jdk1.6.0_01\bin\; on Windows.

You might have put your Java installation somewhere different on Vista. Please check.
 
Chengwei Lee
Ranch Hand
Posts: 884
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just go to the command prompt and try this:


If it shows the Java version, then there's no issue with your PATH settings. Else you'll have to set it in your environment variables.
 
Ricky Clarkson
Ranch Hand
Posts: 131
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The simplest way is to make CLASSPATH not exist at all, and PATH include the bin directory for the JDK.

I have no idea why this isn't done for you.
 
jide agboola
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks a lot, i got it working, i only set the CLASSPATH initially and not the PATH, now it all done.once again thanks..
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!