• Post Reply Bookmark Topic Watch Topic
  • New Topic

error  RSS feed

 
jayaprakash Rengaswamy
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Pls. clarify the following error message:
=========================================

App2.java:6: App2 is not abstract and does not override abstract met
rformed(java.awt.event.ActionEvent) in java.awt.event.ActionListener.
 
Joel McNary
Bartender
Posts: 1840
Eclipse IDE Java Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It means two things:

1). The actual problem: Your class App2 implements ActionListener but does not define the method "actionPerformed" which takes an ActionEvent as a parameter. There are two ways to solve this:
- a). Make your class App2 abstract.
- b). define the method in the class.

2). It also means that your console display is not wide enough to show the entire column width that the console is printing (or your cut-and-paste didn't capture it all), as there is some missing text ("hod actionPe", to be specific). If you didn't understand the error message, that's why.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!