• Post Reply Bookmark Topic Watch Topic
  • New Topic

Newb needs a lot of help...  RSS feed

 
Andrew Andrees
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, I've downloaded the Java SDK, I've got Notepad++ from my TI83+ ASM days, and now whenever I do anything, I'm messed up, I try following the guides, saving in appropriate places, but the problem is, for some reason the CMD won't accept javac as a command. I saved the java SDK in C:\Program Files\Java. I'm using XP. Help?
 
pete stein
Bartender
Posts: 1561
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
please check that your operating system's system path can find javac. If you search this or any other java forum on javac and path (or system path), you'll find a goldmine of useful information.

Good luck!

Pete
 
Nicholas Jordan
Ranch Hand
Posts: 1282
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have wrestled this several times, it depends on how you want to approach the problemj.

First, you really have to know where javac (not java.exe) was installed to.

That is taken as a string, and fed into set path =""

which will not be saved past the 16-bit session if you stay in the window provided by the cmd shell, and the win contemporary os does not really use the 16-bit stuff in it's 32-bit operation so you can do it the way that makes sense to you.

One way to do that is save the commands that you find to work in a text file, then save that file as compile.bat or run.bat on win platforms. This leaves command shells laying around. Not a big deal at this level of work.

I happen to like TextPad, it seems to be able to pick up the needed information from the registry.

I saved the java SDK in C:\Program Files\Java

did you save it or run the installer ?

given the above, I would open Notepad:

set path="C:\Program Files\Java\bin"
javac -cp . *.java


then file save and open from the shell.
 
Andrew Andrees
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, I've installed Java in the program files under Java, and when I tried that set path= thing, the cmd spits out

PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Common Files\Sonic Shared;;C:\PROGRA~1\TIEDUC~1\TI-83P~1UTILS;C:\PROGRA~1\TIEDUC~1\TI-83P~1\UTILS;C:\SIERRA\BIN;C:\Program Files\Common Files\GTK\2.0\bin

I have no clue. And i'm still confused on the system path. What am I supposed to direct it towards? I know how, just not what.

And thank you.
 
Jinny Morris
Ranch Hand
Posts: 103
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This link gives the best directions I've found for getting to the path variable in Windows XP for a non-expert. Once you get to the properties you'll see 2 windows: one is labelled User variables and the other is labelled System variables. If you scroll down in the User variables you'll find one called "path". Select it and click "Edit". Then add the complete location of your javac executable to either the beginning or the end of the path, remembering that the various "paths" must be separated by semicolons. For example, I added mine to the end; so I typed

;C:\Program Files\Java\jdk1.6.0_01\bin

to the end of the path. You need to go all the way to "bin" because that's where both the javac and the java executables are stored. You may have a more recent update of the jdk than I have; so check in Windows Explorer to be sure what to use.

Good luck!
[ September 30, 2007: Message edited by: Jinny Morris ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!