• Post Reply Bookmark Topic Watch Topic
  • New Topic

problem while deploying EJB jar file

 
kirankumar valiveti
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am facing a problem while deploying EJB jar file. Actually we are migrating from weblogic 8.1 to 10. To avoid BEA-010212 warning on screen i changed Doctype from

<!DOCTYPE weblogic-ejb-jar PUBLIC '-//BEA Systems, Inc.//DTD WebLogic 8.1.0 EJB//EN' 'http://www.bea.com/servers/wls810/dtd/weblogic-ejb-jar.dtd'>

to
<weblogic-ejb-jar xmlns="http://www.bea.com/ns/weblogic/920" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.bea.com/ns/weblogic/920 http://www.bea.com/ns/weblogic/920/weblogic-ejb-jar.xsd">

I am getting the following error.

<Aug 25, 2008 2:44:18 PM IST> <Error> <Deployer> <BEA-149205> <Failed to initialize the application 'MyEJB' due to error weblogic.application.ModuleException: Exception preparing module: EJBModule(MyEJB)
[EJB:011023]An error occurred while reading the deployment descriptor. The error was:
Unmarshaller failed..
weblogic.application.ModuleException: Exception preparing module: EJBModule(MyEJB)
[EJB:011023]An error occurred while reading the deployment descriptor. The error was:
Unmarshaller failed.
at weblogic.ejb.container.deployer.EJBModule.prepare(EJBModule.java:399)
at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:93)
at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:360)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:26)
at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(DeploymentCallbackFlow.java:56)
Truncated. see log file for complete stacktrace
com.bea.xml.XmlException: failed to load java type corresponding to e=weblogic-ejb-jar@http://www.bea.com/ns/weblogic/920
at com.bea.staxb.runtime.internal.UnmarshalResult.getPojoBindingType(UnmarshalResult.java:329)
at com.bea.staxb.runtime.internal.UnmarshalResult.determineTypeForGlobalElement(UnmarshalResult.java:296)
at com.bea.staxb.runtime.internal.UnmarshalResult.determineTypeForGlobalElement(UnmarshalResult.java:306)
at com.bea.staxb.runtime.internal.UnmarshalResult.determineRootType(UnmarshalResult.java:287)
at com.bea.staxb.runtime.internal.UnmarshalResult.unmarshalDocument(UnmarshalResult.java:153)
Truncated. see log file for complete stacktrace

Please see the weblogic-ejb-jar.xml file below.

<?xml version="1.0" encoding="ISO-8859-1"?>

<weblogic-ejb-jar xmlns="http://www.bea.com/ns/weblogic/920" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.bea.com/ns/weblogic/920 http://www.bea.com/ns/weblogic/920/weblogic-ejb-jar.xsd">

<weblogic-enterprise-bean>
<ejb-name>MyEjbName</ejb-name>

<transaction-descriptor>
<trans-timeout-seconds>36000</trans-timeout-seconds>
</transaction-descriptor>

<enable-call-by-reference>True</enable-call-by-reference> <jndi-name>
MyJndi</jndi-name> </weblogic-enterprise-bean>
<transaction-isolation>
<isolation-level>TRANSACTION_READ_COMMITTED</isolation-level>
<method>
<ejb-name>MyEjbName</ejb-name>
<method-intf>Home</method-intf>
<method-name>*</method-name>
</method>
<method>
<ejb-name>MyEjbName</ejb-name>
<method-intf>Remote</method-intf>
<method-name>*</method-name>
</method>
</transaction-isolation>
<disable-warning>BEA-010001</disable-warning>
<disable-warning>BEA-010212</disable-warning>
</weblogic-ejb-jar>

Please tell me what i am doing wrong.

Thanks
Kiran
 
Matt Cartwright
Ranch Hand
Posts: 152
Linux VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Kiran,

you already posted the reply

it's in the XSD

From WLS 9.x onwards you gotta have your entries in exactly the same
order as listed in the XSD.

Thus, your <transaction-descriptor> tag needs to go right before your
<transaction-isolation> tag.

Hope that helps.
 
kirankumar valiveti
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Matt Cartwright,

But in my xml file <transaction-descriptor> tag is right ahead to <transaction-isolation> tag, that you can see in my previous post. So some thing other than this is making the problem.

Regards,
Kiran
 
William Dimaculangan
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just in case anyone else runs into this, the xmlns needs to remain "90".

xmlns="http://www.bea.com/ns/weblogic/90"
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!