Win a copy of Learning OpenStack Networking: Build a solid foundation in virtual networking technologies for OpenStack-based clouds this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Knute Snortum
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Ganesh Patekar
  • Stephan van Hulst
  • Pete Letkeman
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Ron McLeod
  • Vijitha Kumara

Strange EJB3 MDB Problem  RSS feed

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using jboss4.0.5.GA.
I have a mdb which is bound to a queue. This queue is already having some messages lying which i could see in the jboss web-console. The queue depth was set to 11. But somehow the mdb is not processing these messages. I have put a println statement in my onmessage and even that did not print on console.
I verified if the queue name i have mentioned in my code file is the same as of the one whose depth was set and that is ok.
This is very strange as i have never seen this happen. There is no error on jboss console on in my logs.I would appreciate if someone can help me here.
 
Sunil Huilgol
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please disregard my above post as it WAS a queue name issue.
However I did see a Communication issue in my log saying "Could not connect to localhost:1100". Possibly that was the reason the mdb did nor start up as the queue request had a comminication issue.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!