• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

setting system property -D option in JNLP file  RSS feed

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am able to execute my client from command prompt using :
java -Djavax.net.ssl.trustStore=myKeyStore -Djavax.net.ssl.trustStorePassword=myPassword MyClient
But now, I want to deploy MyClient using WebStart. any idea on how i can configure the above -D option in JNLP file?
thanks for any help.
 
sathi rv
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
nobody to help me out :-(
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You should be able to specify runtime properties in your JNLP file using the property tag, e.g.,



See the vamphq JNLP tag reference for more information. There are also good FAQs at that site.

Jim
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have same problem. Please give me the solution.
 
Marshal
Posts: 24467
55
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Venkat, adding a post like that to an old post is not a good idea. If you have the same problem, then why isn't the answer already given the answer to your problem?
 
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The suggested approach (to add the property to the resources section in the JNLP file) in Java 6 only works for "secure" properties. Properties are considered secure in this context if they start with "javaws." or "jnlp." -- so the example doesn't work -- at least not in Java 6.
In Java 5, I think it does work, but if your user has Java 6 instead, (s)he'll be in trouble.

In my case I've solved it by passing the property on the command line:
> javaws -J-Dcom.my.prop=hello thefile.jnlp
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!