Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Error loading WebappClassLoader

 
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Folks,
I am geetting the below error, which says that it is not able to find the servlet class.
Nov 18, 2008 5:11:39 PM org.apache.catalina.core.ApplicationContext log
INFO: Marking servlet logincheck as unavailable
Nov 18, 2008 5:11:39 PM org.apache.catalina.core.ApplicationContext log
SEVERE: Error loading WebappClassLoader
delegate: false
repositories:
/WEB-INF/classes/
----------> Parent Classloader:
org.apache.catalina.loader.StandardClassLoader@12d3205
com.tvs.tran.servlet.Logincheck
Could someone help me on this. Thanks
 
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First check whether you have all the library files in the lib directory inside the WEB-INF directory.

Can you put the log message you are getting to probe more.
 
renu richard
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Please see below the console logs.


Thanks
 
renu richard
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Guys,
Someone Please help me on this....
 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It seems that the class com.tvs.tran.servlet.Logincheck is missing.
Make sure there is the .class file WEB-INF/classes/com/tvs/tran/servlet/Logincheck.class.
Or some other reason, I'm not sure.
 
renu richard
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah....you are right. I am running this in eclipse. The class files are not getting created in that location. Not sure why this is missing. Is any jars missing ? If so, wont it tell in the logs?

Thanks
 
Ranch Hand
Posts: 697
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As li bei pointed out you are probably missing the Jar file which contains the LoginCheck.class.

There's a handy tool that you can use with Eclipse which is called the JAR Class Finder.

It helps you locate the name of the JAR which contains the class you're looking for.

You might want to give it a try.
 
    Bookmark Topic Watch Topic
  • New Topic