Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Struts version for Weblogic 9.2

 
Sat Nar
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Is there any specific version of struts that we need to use for weblogic 9.2?

I had an application running in Weblogic 8.1 and it was working fine. Now we moved to Weblogic 9.2. Now we are facing with lot of struts related errors.

Kindly help me out. Also how to find the version of the struts?

Thanks in advance.
 
Joe Ess
Bartender
Posts: 9319
10
Linux Mac OS X Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Sat Nar:
Is there any specific version of struts that we need to use for weblogic 9.2?


No.
I'm not aware of any easy way to determine the version of Struts.
You'll have to fill us in on the details of your situation. What errors are you seeing? How are you building and deploying your application? How are you including struts.jar?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not aware of any easy way to determine the version of Struts.

It's in the manifest file.

Dave
 
Joe Ess
Bartender
Posts: 9319
10
Linux Mac OS X Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That would make sense, but I don't see it:
Manifest from struts2-core-2.0.11.jar:

Manifest from whatever version is included with Weblogic 8.1:
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm; weird. Maybe we started doing that in S2.1. In S1 the version is there from at least 1.2.7+.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic