• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Deployment problem

 
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear Tomcat experts,

At the company where I'm working, we have three production machines (10Gb internal memory each ), and on each Tomcat 6.0.14 is installed.
On each of these Tomcats several webapplications are running, among which one that is developed by me.

Now, as long as I'm here, something weird is happening. Often, just after an update (about half an hour after the update), Tomcat crashes. Nothing can be found in all of the logfiles! This will happen 3 to 4 times arbitrarily on any of the servers. Then, it will run without any problems for weeks (up to the next update .

We tried to vary the way updates were done (the system administrator does this for us). In the beginning we used the manager webapplication. Later, the administrator uses bin/shutdown.sh, then overwrites the .war and removes the directory of the extracted .war, followed by bin/startup.sh.

They also tried just to update some files, overwriting them in the directory of the extracted .war (but also first bin/shutdown.sh, later bin/startup.sh).

It is really getting annoying and we have to solve this. I was thinking to measure the memory usage. And maybe attach a Java profiler (I tried Yourkit on my imac here).

I hope somebody has a good tip for me to tackle this problem.

java.version = 1.5.0_13


Oh yes, one more thing. Sometimes I find this message in the catalina.out logfile:
Invalid memory access of location 00000004 rip=81ce3865
It's quite a mystery to me where this messages comes from.
When this happens the server also crashes, but these two problems might very well not be related.

Thanks in advance !
John.
reply
    Bookmark Topic Watch Topic
  • New Topic