• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Ganesh Patekar

Running JBOSS 4.2.3 and java 6 on mac os x leopard

 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good day all,

I am a Java developer who has being running java applications(j2se/j2ee) on the windows platform, though I am new to the MAC OS X world, I however find it quite interesting, I have a MacBook running version 10.5.4 I have eclipse and Netbeans running beautifully as well as MySql, I however have issues running JBOSS this has given me lots of trouble. To that effect I am posting this lenghty jboss console messages for you all to please look through and give me help which I am in dire need of


taysay-shaguys-macbook:jboss taysayshaguy$ cd /Applications/jboss .DS_Store jboss-4.2.3.GA/
taysay-shaguys-macbook:jboss taysayshaguy$ cd /Applications/jboss/jboss-4.2.3.GA/bin
taysay-shaguys-macbook:bin taysayshaguy$ run.sh
-bash: run.sh: command not found
taysay-shaguys-macbook:bin taysayshaguy$ ./run.sh
./run.sh: line 89: ulimit: open files: cannot modify limit: Invalid argument
run.sh: Could not set maximum file descriptor limit: unlimited
=========================================================================

JBoss Bootstrap Environment

JBOSS_HOME: /Applications/jboss/jboss-4.2.3.GA

JAVA: java

JAVA_OPTS: -Dprogram.name=run.sh -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

CLASSPATH: /Applications/jboss/jboss-4.2.3.GA/bin/run.jar

=========================================================================

13:43:01,939 INFO [Server] Starting JBoss (MX MicroKernel)...
13:43:01,939 INFO [Server] Release ID: JBoss [Trinity] 4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)
13:43:01,944 INFO [Server] Home Dir: /Applications/jboss/jboss-4.2.3.GA
13:43:01,944 INFO [Server] Home URL: file:/Applications/jboss/jboss-4.2.3.GA/
13:43:01,945 INFO [Server] Patch URL: null
13:43:01,945 INFO [Server] Server Name: default
13:43:01,945 INFO [Server] Server Home Dir: /Applications/jboss/jboss-4.2.3.GA/server/default
13:43:01,946 INFO [Server] Server Home URL: file:/Applications/jboss/jboss-4.2.3.GA/server/default/
13:43:01,946 INFO [Server] Server Log Dir: /Applications/jboss/jboss-4.2.3.GA/server/default/log
13:43:01,946 INFO [Server] Server Temp Dir: /Applications/jboss/jboss-4.2.3.GA/server/default/tmp
13:43:01,946 INFO [Server] Root Deployment Filename: jboss-service.xml
13:43:02,179 INFO [ServerInfo] Java version: 1.5.0_16,Apple Inc.
13:43:02,180 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_16-133,Apple Inc.
13:43:02,180 INFO [ServerInfo] OS-System: Mac OS X 10.5.4,i386
13:43:02,465 INFO [Server] Core system initialized


OTHER TYPICAL JBOSS MESSAGE

I Depend On:
jboss:service=TransactionManager
jboss.jca:service=DataSourceBinding,name=DefaultDS

ObjectName: jboss.web.deployment:war=web-console.war,id=1092359086
State: FAILED
Reason: org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable: (javax.management.RuntimeOperationsException: Exception invoking method init)
I Depend On:
jboss.admin:service=PluginManager

ObjectName: jboss.web.deployment:war=invoker.war,id=65268563
State: FAILED
Reason: org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable: (javax.management.RuntimeOperationsException: Exception invoking method init)

ObjectName: jboss.web.deployment:war=ROOT.war,id=-2088321142
State: FAILED
Reason: org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable: (javax.management.RuntimeOperationsException: Exception invoking method init)

ObjectName: jboss.web.deployment:war=jbossmq-httpil.war,id=-738882883
State: FAILED
Reason: org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable: (javax.management.RuntimeOperationsException: Exception invoking method init)


13:43:29,049 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080
13:43:29,056 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
13:43:29,058 INFO [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)] Started in 27s:110ms

at this point calling the URL in my browser returns no response at all infact the brower just stares at me.

2, At the same time when I try to update my jdk with JavaForMacOSX10.5Update2.dmg from apple all I get is 1.5.0_16 is that same for 1.6.x

I will apprecaite your help very much thank you and sorry for the trouble.

regards Taysay
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think this is because of one of the common issues that have been reported in forums starting JBoss-4.2.3 GA For JBoss-4.2.3 GA, the download site has 2 different downloads. One is for JDK 1.5 and the other for JDK 1.6.

Going by the "date" of this build:

[4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)]



I think you downloaded the JDK 1.6 version of JBoss-4.2.3 and are using it with JDK 1.5:


13:43:02,179 INFO [ServerInfo] Java version: 1.5.0_16,Apple Inc.
13:43:02,180 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_16-133,Apple Inc.



You have 2 options:
1) Download JDK 1.6 (not sure if there's one available for Mac) and use it with JBoss-4.2.3 GA
OR
2) Downaload the JBoss-4.2.3 GA for the JDK 1.5 version and use it with your current JDK.

Originally posted by Terseer Shaguy :
At the same time when I try to update my jdk with JavaForMacOSX10.5Update2.dmg from apple all I get is 1.5.0_16 is that same for 1.6.x



No they are not the same.
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Going by the "date" of this build:

[4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)



By the way, for my JBoss-4.2.3 GA for JDK 1.5, i see this build info:



So after you download the JBoss-4.2.3 GA for JDK 1.5, you can compare these dates.
 
Terseer Shaguy
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
@Jaikiran Pai

How are you doing, Thank's alot I didnt know that the topinc was moved in here so I was only looking at your post on JBoss.org, I apprecaite that very much I wll do all that over the weekend when I have time for myself, then get back to you.
Have a wonderful weekend
 
Terseer Shaguy
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
@Jaikiran Pai
How are you doing, just to appreciate you invaluable assistance. Yes changing the installation of jboss from jboss from 4.2.3-GA-jdk 6 to jboss from 4.2.3-GA solves the problem though running jboss-seam 2.1.0 on it throws the following issues

An error has occurred while processing the Maven artifact tasks.
Diagnosis:
Unable to resolve artifact: Missing:
----------
1) javax.xml.bind:jaxb-api:jar:2.1
Try downloading the file manually from the project website.
Then, install it using the command:
mvn install:install-file -DgroupId=javax.xml.bind -DartifactId=jaxb-api -Dversion=2.1 -Dpackaging=jar -Dfile=/path/to/file
Alternatively, if you host your own repository you can deploy the file there:
mvn deploy eploy-file -DgroupId=javax.xml.bind -DartifactId=jaxb-api -Dversion=2.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
Path to dependency:
1) org.apache.maven:super-pom:jar:2.0
2) javax.xml.bind:jaxb-api:jar:2.1
----------
1 required artifact is missing.
for artifact:
org.apache.maven:super-pom:jar:2.0................. blah blah
changing the jboss-seam installation to jboss-seam-2.1.0.SP1.tar solves the problem. Thank you so very much.

Have a bug free week
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Terseer,

Good to see that you got it working
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!