Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

sending Mime response using HttpServletResponse stream  RSS feed

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having an application where a user viewing a page , clicks on a link and gets the mht of that html page ,

so when clicked the html of page is send to server , and in server side we do some processing and create a MultiPart Mime message and send it to client through HttpServlet Response.
and on client side page opens in a seperate webpage in IE.

so user clicks ones , he is getting the response but second time he clicks page gets closed , it is happening alternatively.

when user clicks he gets a dialog-box saying "save" or "open" , when click save ,everything works fine , but when click on open it is not working alternatively.
and address of IE gets changed to mhtml:http://<hostname>/reportserver/default.mht
 
indresh mishra
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
part of code is as follows:
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

indresh mishra wrote:part of code is as follows:



Hi, i know its been a long time but i'm very interested in this approach of yours..

Did you have success with the generated mhtml file?
In my case the page in the mthml format goes "wild". Css is not well read and images are not being displayed. The encoding is the to UTF-8 just like yours.
Any clue? Thanks!
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!