Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WEbSphere Portal Server 6.0 - Locale Problem.

 
Kumar Anupam
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Everbody.

We have below issue in our application .... The prompt suggation is really appreciated. Many thanks in advance.

We have a processor which does below taks
This processor
1) Gather parameter from request,
2) Check is Language Toggling Triggered (Language could be en_US / zh_TW)
If yes
3)Create Locale
4) by using LocaleAccessorController.setLocale(locale) setting up the locale.

The LocaleAccessorController can be used to set a special locale into the navigational state and thus into a URL.
Note: A locale retrieved from such a URL takes precedence over user preferred locales or locales defined on the user’s browser

We have another Processor to which the consequent request goes and retrives the Locale value from PortletRequest.
When locale is fetched from portLetRequest.getLocale(), it is always returning en_US as Locale.(Which is default Locale set from the application.)

Now question here is -

1) Is there any setting that we have to do in our Portal environment that make LocaleAccessorControllereffective. If yes, which is that?
2)Is their any other solution to this problem.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic