Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

AXIS1.4- webservice cleint Issue

 
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello Friends
I am using AXIS1.4 fow webservice cleint.
I have generated stubs using WSDL2Java of axis.
It has generated classes and other additional class like:-

ServiceLocator
Port
PortStub
Service

But when i am using ,
Service service=new ServiceLocator();
PortStub stub=PortStub(endPoint,service);

endpoint-wsdl URl;

its giving me java.lang.NullPointerException .
PLease guide me to resolve my issue.

I can't move to axis upgarde versions.

I tried lot googling but still stuck. PLEASE PROVIDE any code snippet if possible.

thank in advance.
 
Bartender
Posts: 2968
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Axis 1.x client code tends to follow the same pattern:

service := serviceLocator
port := service.getBindingStub( differentUrl )
response := port.webMethod(request)




See also Creating Web Services with Apache Axis (1.x)

The above code comes from an example discussed in Empty Namespace in SOAP (Axis 1.4).
 
ashirvad jain
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your kind reply.

I some how able to solve that issue.
Actually i was troubling to get web cleint . I referred lot of document and rest info.
Actually i was facing some configuration issue with eclipse.so was not able to solve that.
But now its solved somehow

But i really appriciate your reply.

Do best and keep posting..

Thank you.
 
If you are using a rototiller, you are doing it wrong. Even on this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic