• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

xdoclet plugin for eclipse - configuring xdoclet

 
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm using xdoclet within eclipse to generate the ejb descriptors and local/remote/session classes. I've recently hit a problem on my project where I get a OutOfMemoryError during the generation. This is using eclipse europa on windows xp.

The xdoclet plugin seems to use ant so the suggestion in the error message is to increase the memory available to ant using the ANT_OPTS property. I'm not sure how to get eclipse to recognise this property? I've done some searching via google and couldn't find anything useful. The xdoclet plugin doesn't seem to have much in the way of configuration options and if I set the ANT_OPTS in the Windows environment variables, eclipse doesn't seem to recognise it!

I've discovered a way of manually running the xdoclet build by using the tempAnt.xml ant build file that eclipse produces in the \workspace\.metadata\.plugins\ directory of the xdoclet plugin but am sure there must be a better way of doing this.

Any help will be much appreciated.

 
Paul Beckett
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Found a fix for this problem.

In the eclipse window preferences go to:

Java\InstalledJREs\

and edit the jre you are using. You can then add some default VM arguments and the xdoclet build uses these.

Such a simple solution but a pain to find.
 
reply
    Bookmark Topic Watch Topic
  • New Topic