Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

validation problem  RSS feed

 
eve agostini
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
I have a problem validating a form.
Validation works but an invalid value doesn't prevent the form to be submitted. I mean, if some other values that are required are missing, i correctly see the validation error message for the invalid values, but if all values are provided than the form is submitted, even if there are still some invalid values.
Anyone ever experienced a problem like that?
It is very very strange because I always use validation and it always works fine.
I would post the code but it's a little complicate because the form is built dynamically. Maybe that's actually the point. But anyway this is strange because it's not like validation doesn't work at all but it just doesn't "block" the submit.

thanks for any help

eve
 
Bauke Scholtz
Ranch Hand
Posts: 2458
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you using the immediate attribute anywhere?

Else it may be worth the effort to nail down the problem and provide an SSCCE of the problem. Remove *all* irrelevant code until you have the smallest possible working code snippet which still exhibits the problem and post it here.
 
eve agostini
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No i'm not using immediate....I had alredy checked that.
You're right, I think I'll try to create something simple enough to be posted.
Thank you
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!