Bookmark Topic Watch Topic
  • New Topic

Tomcat not starting  RSS feed

 
randhir sethi
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Report post to moderator
My requirement is to copy tomcat from our live server to a new server with better configurations. So, for this migration, I copied the tomcat to the new server. But, the tomcat is not starting as I am not able to see my application URL. It could also be that tomcat is ok but the web application is not getting deployed.

I hope, my question is clear.

Please, help in solving the doubt.

regards
 
Bauke Scholtz
Ranch Hand
Posts: 2458
  • Mark post as helpful
  • send pies
  • Report post to moderator
Have you read the logs?
 
randhir sethi
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Report post to moderator

thanks, for your answer. The catalina.out log file shows following kind of output:-

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Jan 28, 2009 4:03:17 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 10080
Starting service Tomcat-Standalone
Apache Tomcat/4.1.24
WebappClassLoader: validateJarFile(/opt/dpc/billing501/wars/corereports/reportstool/WEB-INF/lib/servlet.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
##### [WebReportsInitializationServlet]:Path of Configuration file :/opt/dpc/billing501/wars/corereports/reportstool/xml/DefaultSystemConf.xml
File can't be deleted
File can't be deleted
File can't be deleted
strParamVal : ReportsServer
Couldn't find the property: ReaderFactory in ReportsServer.properties
Taking default value to: LocalRMI
*** ReportsServer.properties: Couldn't find the resource Connection.Unique.Alias, setting it to RPTS ***
Couldn't load any service
*** ReportsServer.properties: Couldn't find the resource Server.ResponseCode.Property, setting it to ReportsServerResponseCode ***
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

regards
 
Bauke Scholtz
Ranch Hand
Posts: 2458
  • Mark post as helpful
  • send pies
  • Report post to moderator
Start fixing the first error:
randhir sethi wrote:
WebappClassLoader: validateJarFile(/opt/dpc/billing501/wars/corereports/reportstool/WEB-INF/lib/servlet.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
 
randhir sethi
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Report post to moderator
thanks, for the answer. I am not a developer as such, I am a implementation guy. How can I proceed to fix this error?

regards.
 
Bauke Scholtz
Ranch Hand
Posts: 2458
  • Mark post as helpful
  • send pies
  • Report post to moderator
Uh, just contact the developer?
 
Joe Ess
Bartender
Posts: 9429
12
Linux Mac OS X Windows
  • Mark post as helpful
  • send pies
  • Report post to moderator
Please do not post the same question more than once.
It wastes people's time when redundant conversations take place.
CarefullyChooseOneForum
 
Don't get me started about those stupid light bulbs.
    Bookmark Topic Watch Topic
  • New Topic
Boost this thread!