• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • Devaka Cooray
Saloon Keepers:
  • Ganesh Patekar
  • Tim Moores
  • Carey Brown
  • Stephan van Hulst
  • salvin francis
Bartenders:
  • Ron McLeod
  • Frits Walraven
  • Pete Letkeman

Jadclipse not working with Eclipse Ganymede 3.4.1  RSS feed

 
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am trying to use jadclipse 3.3.0 with eclipse 3.4.1, but it is not working (earlier I tried to use it with eclipse 3.3 as well but was getting the same behavior).

Following is my configuration (Windows XP):
  • Jadclipse - 3.3.0
  • Jad - 1.5.8g
  • Eclipse - 3.4.1
  • Java - 1.5.0_03-b07


  • I have followed installation steps as below, but whenever I try to open a .class file, it is opened by Eclipse default class file editor and not by jadclipse showing source code.

    1. I installed jadclipse using update site - http://webobjects.mdimension.com/jadclipse/3.3.
    2. I restarted eclipse, using eclipse -clean from command prompt.
    3. I configured jadeclipse - set path (screenshot attached).
    4. I added jar, classes to be decompiled to project's classpath.
    5. Also added jad executable to windows environment path.

    But nothing seems to work for me.

    Please help me in resolving this issue.

    Update
    If I [CTRL] + left click on a class name in jar file then jadclipse opens it. But if I double-click .class file in navigator OR during debugging file is opened by Default class file editor.


    Regards,
    Ajay
    jadc1.JPG
    [Thumbnail for jadc1.JPG]
     
    Greenhorn
    Posts: 1
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Hi Ajay,

    Jadclipse 3.3.0 still works in my Ganymede, so it should be possible to get it working.

    Could you try the following? (from http://jadclipse.sourceforge.net/wiki/index.php/Main_Page#Troubleshooting)


    Problem: The Eclipse Class File Viewer instead of the JadClipse Class File Viewer is opened.
    Go to Window > Preferences... > General > Editors > File Associations and make sure that the JadClipse Class File Viewer has the default file association for *.class files.



    For me it looks like the attached picture.

    Good luck!
    Ivor
    jadclipse.PNG
    [Thumbnail for jadclipse.PNG]
    Jadclipse Configuration
     
    Ajay Kamble
    Ranch Hand
    Posts: 51
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Hi Ivor,

    Thanks for your reply.

    I went through your reply and link that you provided.

    My .class file association is correct, I have jadclipse as default editor, just like snapshot provided by you.

    My all configuration pieces are correct, like path to jadclipse exe, .class file association. But still it doesn't work.

    I guess I am missing something else but can't figure it out.

    Ivor, thanks for your help.

    Thanks & Regards,
    Ajay
     
    • Post Reply Bookmark Topic Watch Topic
    • New Topic
    Boost this thread!