• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

remote debugging with tomcat and eclipse  RSS feed

 
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I have tried following what is available on internet for enabling remote debugging of web application using tomcat and eclipse but somehow it is not working for me.

I am using jdk1.5.0_09, eclipse Version: 3.2.1, apache-tomcat-6.0.18 and com.sysdeo.eclipse.tomcat_3.2.1
I have set JVM arguments in eclipse -> windows -> perferences -> tomcat -> JVM Setting as
-Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=1044

now i see the three icons for tomcat start, stop and restart but when I click on start icon I am getting following error:

ERROR: JDWP unable to get necessary JVMTI capabilities. ["debugInit.c",L279]

any idea what is missing or wrong here.........

quick response is appreciated
Thanks in advance.
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!