Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JDK backward compaitability in WebSphere 6.1

 
Arockia Raj
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
We are migrating our application to WebSphere 6.1 which has jdk1.5 as runtime environment.Our application is compaitable with jdk1.4.02 and we need to run this application in WebSphere 6.1 by providing backward compaitability for jdk1.5.

Kindly let us know how to configure the application to run with jdk1.5.We are compiling our application in jdk1.5 with backward compaitability to jdk1.4.
 
Paul Clapham
Sheriff
Posts: 21316
32
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you use Websphere 6.1 it will run your application under Java 5. There isn't any configuration possible, or necessary. If you wrote your application so that it would also run under Java 1.4 that is nice but irrelevant in this case.
 
Arockia Raj
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Paul,
Thanks a lot for your quick response.

We will compile our application in JDK1.5 with backward compaitability to jdk1.4.If we deploy this application in websphere 6.1,do we face any problems..
 
Paul Clapham
Sheriff
Posts: 21316
32
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Arockia Raj wrote:If we deploy this application in websphere 6.1,do we face any problems..


Of course there are all sorts of potential problems. But Websphere 6.1 runs applications under Java 5, so if you compile your application under Java 5 then you shouldn't have any problems related to the compiler level.
 
vamsheedhar devarishati
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I do not think ...you will have a probelms with JDK1.4 ...

The only problems you will see with your app ex : webservices , java code ...

Ex : in your app code if you have any word like enum , then this class won"t compile in 5 because this is a key word in jdk1.5..so you need to change the code ..in order to compile ...

i bet you will see lot of application problems and may need to update thirdparty jarsssssssssss

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic