• Post Reply Bookmark Topic Watch Topic
  • New Topic

why the jstl tag displayed with three question marks?  RSS feed

 
laoying Yin
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
when I use jstl in my page, some of the tags were failed to display, they became this: ???page.index.global??? on page.

Anyone can help? I can't google something useful
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65833
134
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you not think that it would be useful to show the code that's causing the problem?

In any case, I'm inferring that you are using the <fmt:message> (or related) tag and that means that the property could not be found in the bundle (or that the bundle itself was not found).

Please read this.
 
laoying Yin
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for the reply.

Just like what you say, following is the sample code from my project. And I check the locale property file, the property "page.column1.sponsor" is there.

code: <fmt:message key="page.column1.sponsor"/>

page: ???page.column1.sponsor???
 
laoying Yin
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Bear, your answer is right. The properties files were not copied into the deploy folder, so they became ??? on web page.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!