• Post Reply Bookmark Topic Watch Topic
  • New Topic

Page load fails in <c:forEach tag  RSS feed

 
Matthew Snow
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


My JSP pages that don't have this snippet load just fine. Those that do only fully load after Refreshing the browser or not at all. Through the process of elimination, it seems the page load fails in the <c:forEach tag. The taglib I'm importing is ><%@ taglib uri="http://java.sun.com/jstl/core" prefix="c" %>.
 
Bauke Scholtz
Ranch Hand
Posts: 2458
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's an ancient JSTL URI.

Which JSTL version are you using? If you can, upgrade to latest JSTL and use the new URI.
 
Matthew Snow
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, this must be a browser thing. I'm using javax.servelt.jstl version 1.2 in my pom. I changed to jstl.jstl version 1.1.2 and my pages started working properly. I switched back to javax.servlet.jstl just to make sure that this indeed was the issue, and my pages still worked! Yes, I did clear may cache ... repeatedly. For the record, I am using Internet Explorer 7, which probably explains everything . Thanks for the reply.
 
Bauke Scholtz
Ranch Hand
Posts: 2458
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Heh. Use FireFox or Opera during development before it´s too late.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!