• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Is there any way to not load balance EJB call in WAS cluster?

Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a WAS ND 6.1 cluster containing two nodes. I deploy a stateless session bean in the cluster. I want the two nodes to do things at the same time. I use below way to lookup the EJB on one node:

You can see that I am using node specific JNDI name, NOT clustered JNDI name like "cell/clusters/MyCluster/oneEJB" to lookup the EJB. I hope using node specific JNDI can lookup the EJB on the given node. But it is not...the lookup is load-banlanced. Sometimes I will get EJB on node 1, sometimes I will get the one on node 2.

Is there any way to let me lookup the EJB on a given node in a cluster? I want both the two nodes to do thing through the EJB at the same time.

And my EJB client is out of cluster now. If I put the client in one of the nodes, I guess all the EJB call will be dispatched to the local EJB in the node, right? I know it is for perfomance consideration. But, is there any way to disable it?

Thank you!
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
    Bookmark Topic Watch Topic
  • New Topic