Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

j_security_check is not redirecting to the requested web serivce.  RSS feed

 
priya verma
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi,

I am using form based authentication to protect some web services in WEbsphere 6.1 . Instead of using JSPs for login page and login error page I have used servlets as follows.
<login-config>
<auth-method>FORM</auth-method>
<form-login-config>
<form-login-page>/LoginServlet</form-login-page>
<form-error-page>/LoginErrorServlet</form-error-page>
</form-login-config>
</login-config>


When I send a request to a protected web service, as intended the controls goes to the LoginServlet first. Here I have added following line in the end :
resp.sendRedirect(
"j_security_check?j_username=" + username + "&j_password=" + password);

If a put wrong username or password webpshere then I get proper error message from LDAP ( webpshere enabled authenticatio nmechanism) on console, and controls goes to LoginErrorServlet as expected.
However , when I give correct username ans password, I get stuck at this line and console shows only following message and do not move forward to the requested web service.

[2/23/09 11:17:09:424 IST] 00000031 CacheServiceI I DYNA1001I:WebSphere Dynamic Cache instance named ws/WSSecureMap initialized successfully.
[2/23/09 11:17:09:518 IST] 00000031 ServletWrappe I SRVE0242I: [AppProject} [/axis] [FilterProxyServlet]: Initialization successful.

Can anyone please help me in solving the issue so that after succesful login I reach the protected web service?

Any help would be appreciated!

Thanks
Priya
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!