• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSTL c tag not working  RSS feed

 
Suresh Ramanan
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!

First, i'd like to tell that I did go through the JSP FAQ
I still could not find a way in which i could get my <c> tag working

The problem:
org.apache.jasper.JasperException: The absolute uri: http://java.sun.com/jsp/jstl/core cannot be resolved in either web.xml or the jar files deployed with this application

My project: No Servlets, Only a form.html, action goes directly to "Welcome.jsp" and if the variable userName is empty it goes to "HandleIt.jsp"

So i guess my web.xml has only the <web-app...></web-app> tag.
Please correct me if I'm wrong.

I'm working with JSTL 1.1 (i found that from the manifest file), Servlets 2.4 and JSP 2.0
There's a copy of the jstl.jar in my deployment env's WEB-INF/lib folder

I'm really sorry again if i missed something very obvious.
Please help.
I'll post the code if you think its something wrong there.

Thanks a bunch,
Suresh

 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66207
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you read the FAQs, then you know that jstl.jar is only one of the jars that you need for JSTL 1.1.
 
Suresh Ramanan
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Bibeault!

Thanks a bunch for the prompt reply.
True indeed, i've missed the standard.jar.
I looked up the info at the http://faq.javaranch.com/java/JstlTagLibDefinitions page.
Will include taht jar too and see.
Thanks again.

Best wishes,
Suresh
 
Suresh Ramanan
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
BINGO!

it works now!
I'm in tears!!
Thank you!

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!