Win a copy of The Journey To Enterprise Agility this week in the Agile and Other Processes forum! And see the welcome thread for 20% off.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

NullPointerException when starting ANY Webstart-Application  RSS feed

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Whenever I try to launch any JNLP-file in my browser, I get the following error:

java.lang.NullPointerException
at java.util.StringTokenizer.<init>(Unknown Source)
at java.util.StringTokenizer.<init>(Unknown Source)
at com.sun.deploy.net.proxy.NSPreferences.parseList(Unknown Source)
at com.sun.deploy.net.proxy.NSPreferences.parseFile(Unknown Source)
at com.sun.deploy.net.proxy.WFirefoxProxyConfig.getBrowserProxyInfo(Unknown Source)
at com.sun.deploy.net.proxy.WDefaultBrowserProxyConfig.getBrowserProxyInfo(Unknown Source)
at com.sun.deploy.net.proxy.DynamicProxyManager.reset(Unknown Source)
at com.sun.deploy.net.proxy.DeployProxySelector.reset(Unknown Source)
at com.sun.javaws.Main.initializeExecutionEnvironment(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)



any help is highly appreciated.
 
Sheriff
Posts: 23640
48
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
From the stack trace, you are using Firefox and the deployer is falling down when trying to process your proxy server settings. So have a look at them and see if there's anything peculiar. (Tools, Options, Advanced, Network, Settings.)
 
M Schneider
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks, but I'm not using a proxy at all and the error is the same when I'm using IE.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!