Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Issue with MIME settings in WebSphere

 
Ranch Hand
Posts: 256
Netbeans IDE Firefox Browser Fedora
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

We are facing problem in opening pdf,xls and doc files through IE while the application is deployed on WAS6.1.0.11
We have required mappings in web.xml but it seems its not taking them.
The problem is its opening all the files in IE as text/html which is default if no mapping present.
The same web.xml and mapping works very fine in Tomcat instances.
Please help do we need to do something else ...???
We have already below mapping in WEB.XML of war file.
-------------------------------
 
Ramakanta Sahoo
Ranch Hand
Posts: 256
Netbeans IDE Firefox Browser Fedora
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Any Help Guys!!!
Still royally stumped
 
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi Ramakanta,

did you get the solution?
actually our problem is all about same as you are facing.

we have problem with 2007 format MS oofice reports. like pptx,dox amd xlsx reports are opening as zip file.
we have too set mew mime type for 2007 format reports, but of no use.

we have entered as-

<mime-mapping>
<extension>docx</extension>
<mime-type>application/vnd.openxmlformats-officedocument.wordprocessingml.document</mime-type>
</mime-mapping>

<mime-mapping>
<extension>xlsx</extension>
<mime-type>application/vnd.openxmlformats-officedocument.spreadsheetml.sheet</mime-type>
</mime-mapping>

<mime-mapping>
<extension>pptx</extension>
<mime-type>application/vnd.openxmlformats-officedocument.presentationml.presentation</mime-type>
</mime-mapping>

any clue, where we are lacking?

Thanks,
Manisha
 
Ramakanta Sahoo
Ranch Hand
Posts: 256
Netbeans IDE Firefox Browser Fedora
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Manisha,

Yes, I found the solution but its only for the applications which are deployed in WebSphere App Server.

Steps to follow:
Login to WAS Admin Console.
Go to Virtual Hosts
You will see a link called MIME TYPES
Enter all your mime types there and restart the server
You are Done.

Bye Tc.

-Ricky
 
manisha Gupta Garg
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi Ramakanta,

Thanks for replying ..

yup the solution that you suggested was already in place in our WAS admin console,virtual host.

so to solve this issue, we had to write the code in servlet. Earlier we were opening the report in Iframe in the jsp file.

Thanks,
Manisha
 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Manisha and Ricky,

I am also facing same issue in my application.
I have added through console ,application/vnd.openxmlformats-officedocument.wordprocessingml.document as a mime type and .docx extension.
Or do I need to add application/vnd.openxmlformats as a mime type.

But still its not working.
I am opening a file in a simple jsp after uploading to the server.
Please help...

Thanks
ssn
 
S Nikam
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks guys..Its working fine now!!
I added application/vnd.openxmlformats-officedocument.wordprocessingml.document only

Regards,
ssn
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

S Nikam wrote:Thanks guys..Its working fine now!!
I added application/vnd.openxmlformats-officedocument.wordprocessingml.document only

Regards,
ssn



Hey ,

What is that you tried differently for the next time so that it worked ?

Thanks,
Kumar
 
What do you have in that there bucket? It wouldn't be a tiny ad by any chance ...
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic