• Post Reply Bookmark Topic Watch Topic
  • New Topic

Java 1.5 & IDE 3.2 with jms  RSS feed

 
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I changed the java version( 1.4 to 1.5) in Eclipse3.1.
After that i got one error in jms Queue.
Error : "The type Queue is ambiguous"
How to rectify this error.
 
Java Cowboy
Sheriff
Posts: 16060
88
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The error messages means that there are two classes named Queue, and the compiler doesn't know which of the two you meant.

Look at the import statements in your source file. You're most likely importing the classes and interfaces of two packages which both have a class named Queue. Change the imports to that only the class Queue that you need is imported.
 
Shyam Hai
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for replay.

But i already use this project with java1.4
Now i just update the version java1.5

After that only i got one error in jms Queue.

So i want do please..
 
Shyam Hai
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i already use this project with java1.4

that time no problem its working fine .
when i change the version java1.5


After that only i got one error in jms Queue.

So what i want do please..
 
Bartender
Posts: 11445
18
Android Eclipse IDE Google Web Toolkit Java Mac Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The java.util.Queue interface was added in 1.5.
That is why you are getting the conflict.

Like Jesper said, check your imports.
 
Shyam Hai
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maneesh Godbole

Thank you.........

Now its working fine.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!