• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

B&S: JDK Version

 
Laura Pecoraro
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all

I am doubtful about the JDK to use for my solution... I can use any version of JDK (es. JDK1.4, JDK5...) or I obliged to use a specified version??? If, yes.... what???

Thanks, Laura

P.S. Now, to devel my solution, I use Eclipse 3.2.2 with JDK5...
 
K. Tsang
Bartender
Posts: 3510
16
Android Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First Java SE 1.4 reached its end of service life (obsolete). So for submission it's either v5 or v6. The good thing that it works for v5 is it's backward compatible - this means your code doesn't use any thing that is "since 1.6" accordingly to the API docs. One of these is java.awt.Component.setBounds().

Yet you should do your testing with v6 and say v6 in your version.txt file.

This earlier thread asked the same thing
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic