[Logo]
Forums Register Login
Problem in Eclipse 3.4 running Java program
I have a project that is enabled for Maven2 and Spring in Eclipse 3.4.

Running mvn clean package works correctly.

I have a MainApp class that works fine when I right click and Run Java Application.

What started to happen is ... I add another simple class in the same package and tried to run it. Now I get ...

java.lang.NoClassDefFoundError: com/bankofamerica/mst/sdg/integration/dmtidb/service/NewClass
Exception in thread "main"

I slimmed it down to just this:
package com.bankofamerica.mst.sdg.integration.dmtidb.service;

public class NewClass {
public static void main(String[] args) {
System.out.println("Hello!");
}
}

I looked at the Run Configuration and it looks similiar to the MainApp(which has no problem running and still runs).

I am beating my head wondering what is happening?

Why could MainApp work and NewClass does not?

When I look under the folders, the NewClass.class exists. The build path must be correct b/c MainApp works.

Any setting to check?



Intrigued, I tried this, and it worked for me. I created a new Maven-based project, created two classes with printlns in main(), and they both ran without issue by right-clicking on the class and selecting Run As > Java Application. There must be something else going on, or different about your project that you did not mention.
Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards



All times above are in ranch (not your local) time.
The current ranch time is
Nov 24, 2017 11:49:07.