• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Drools-4.0.7 + OC4J

 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi all,

I am new to drools. I am facing a very strange issue while working with JDeveloper + OC4J 10 + Drools 4.0.7. If I execute my "hello world" program in "debug" mode of JDeveloper then all my rules are working properly. But when I execute it in "run" mode then execution stops at following line
builder.addPackageFromDrl(new InputStreamReader(CreditExample.class.getResourceAsStream("/abc.drl")));

Also there is no exception thrown. Also if I make any syntax error, then exception are thrown(which proves that my .drl file is getting loaded). I don't know what is the problem at run time. Can anyone please help me out

Thanks
Vir
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic