Win a copy of Beginning Java 17 Fundamentals: Object-Oriented Programming in Java 17 this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

No Class

 
Ranch Hand
Posts: 50
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Okay, so I should probably know this but here's the situation.
I was happily compiling code last week. I began looking at Servlets and playing around with the WebLogic Server I have running on my laptop. I needed to send in one of the OOP assignments that was ready. I went to compile and review it before sending it and received this error when I tried to run it:
Exception in thread "main" java.lang.NoclassDefFound Error: classname
I didn't change the classpath. I have even compiled and tried running the program using full path names. Nothing is working. I searched the archives but didn't see a definitive answer. Anyone have any ideas?
 
village idiot
Posts: 1208
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Classpath, why did it have to Classpath? I can't escape from classpath!!!
 
Sheriff
Posts: 9109
12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Ronald Schindler:
I didn't change the classpath.


You didn't change the classpath. Have you installed any new applications lately (maybe you installed WebLogic Server recently)? Sometimes apps change the classpath for you.
 
reply
    Bookmark Topic Watch Topic
  • New Topic