Win a copy of Micro Frontends in Action this week in the Server-Side JavaScript and NodeJS forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

[Eclipse] [Subversive] Can check out project, but it then doesn't register as a Subversion project?

 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
EDIT: Please ignore the 3 posts below. I honestly thought they weren't being posted. Apparently Firefox didn't think the page had changed and so didn't refresh it... Grrr...

EDIT: Known bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=274010

Hey folks, I've got strange problem, I think:

I recently figured I'd check out WSS4J - have a look around and such, as I've been needing to look at the source code a lot recently.

So I installed Eclipse Ganymede. Installed the Maven Plugin and the Subversive Plugin. The Maven Plugin is at version 0.9.7.200902090947.

I have the following Subversive plugins installed:

Subversive Integration for the Mylyn Project (Incubation), 0.7.8.I20090428-1500
Subversive SVN Team Provider (Incubation), 0.7.8.I20090428-1500
Subversive Extension for the M2Eclipse, 1.0.1.I20080612-1500
Subversive SVN 1.4 JavaHL Connector, 2.0.4.I20081001-1900
Subversive SVN 1.4 SVN Kit Connector, 2.0.4.I20081001-1900
Subversive SVN Connectors, 2.0.4.I20081001-1900

I'm running Java 1.5, on Ubuntu 8.04, and the version of SVN I have installed is 1.4.6. I have the Native Java SVN libs installed (libjavahl-1.so), but this error occurs with either SVN Kit or the JavaHL connector.

One of the things I noticed is that I get the following error once everything has been checked out from Eclipse:

An internal error occurred during: "Updating Change Sets for org.eclipse.team.svn.core.synchronize.UpdateSubscriber".
org.eclipse.team.svn.core.connector.SVNChangeStatus.<init>(Ljava/lang/String;Ljava/lang/String;IJJJLjava/lang/String;IIIIZZLjava/lang/String;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;JZLjava/lang/String;Ljava/lang/String;Ljava/lang/String;JLorg/eclipse/team/svn/core/connector/SVNLock;JJILjava/lang/String;)V

Then a huge number (30?) of errors that look like this:

*** Get Resource List
org.eclipse.team.svn.core.connector.SVNChangeStatus.<init>(Ljava/lang/String;Ljava/lang/String;IJJJLjava/lang/String;IIIIZZLjava/lang/String;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;JZLjava/lang/String;Ljava/lang/String;Ljava/lang/String;JLorg/eclipse/team/svn/core/connector/SVNLock;JJILjava/lang/String;)V
*** Error (took 00:00.029)

Until I get this at the bottom:

*** Send Notifications
org.eclipse.team.svn.core.connector.SVNChangeStatus.<init>(Ljava/lang/String;Ljava/lang/String;IJJJLjava/lang/String;IIIIZZLjava/lang/String;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;JZLjava/lang/String;Ljava/lang/String;Ljava/lang/String;JLorg/eclipse/team/svn/core/connector/SVNLock;JJILjava/lang/String;)V
*** Error (took 00:03.299)

If anyone has any ideas, I'd be very interested in hearing them. I can delete my Eclipse install and start again - that's not a major problem, but I'd like to know why this is happening, if at all possible.\

Thanks all.
 
Andrew Adamson
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ah, known bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=274010
 
Andrew Adamson
Greenhorn
Posts: 11
 
Andrew Adamson
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok... Something's broken. I can't edit or reply to this topic...


Anyway, known issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=274010
 
You can't have everything. Where would you put it?
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
reply
    Bookmark Topic Watch Topic
  • New Topic