Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WebSphere Application Server Toolkit - is there a new version?

 
Maciej Miklas
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am developing applications using WAS 6.1. Therfore I am using AST 6.1 - it's based on Eclipse 3.2.

is there version based on Eclipse 3.4? Maybie there is something else based on newest eclipse version (but not RAD)?

Thanks,
Maciej
 
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper
Posts: 4968
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You take what WebSphere gives you when it comes to their packaged software.

So, you are using IRAD though, right? I think installation manager is capable of checking for updates to IRAD.

-Cameron McKenzie
 
Maciej Miklas
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
no - I was using AST - WebSphere Application Server Toolkit.

RAD is not free and it does not comme with WAS.

AST update page does not show new version - this is why I am asking
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34973
379
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maciej Miklas wrote:is there version based on Eclipse 3.4? Maybie there is something else based on newest eclipse version (but not RAD)?

My guess would be that you need to wait until you upgrade to WebSphere 7, to use the tools that were based on the latest Eclipse base.
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34973
379
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to our WebSphere forum since this is pretty IBM specific.
 
Maciej Miklas
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jeanne Boyarsky wrote:
Maciej Miklas wrote:is there version based on Eclipse 3.4? Maybie there is something else based on newest eclipse version (but not RAD)?

My guess would be that you need to wait until you upgrade to WebSphere 7, to use the tools that were based on the latest Eclipse base.


I only found RAD for WAS 7, are there other toole from IBM (they might work with WAS 6)?
 
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper
Posts: 4968
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What are the key tasks you are trying to perform with the WebSphere Application Server Toolkit. Is it preparation for deployment?

Many great packaging tools come with Eclipse, and Eclipse also has a great update tool that allows you to see what other plugins might be available. It might we worth the cost of a download to install the latest version of Eclipse, and hunt around the update tool and see if there are any neat plugins that might make your life easier.

Again, what are the key tasks you are trying to perform. Maybe someone knows of a tool that will hit your sweet spot?

-Cameron McKenzie
 
Maciej Miklas
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1) new WTP does not deploy to websphere - this is known problem
2) I need IDE to hot deploy EAR projects into WAS. I also will start WAS from eclipse - not remote debug

MyEclipse blue works fine, but I've been using myeclipse for 5 years and I would like to try something else (They have lately really poor quality.....).

IBM AST (Eclipse 3.2 WTP + WAS plugins) is just great, but there is no update to Eclipse 3.4 - I've tried it. I've also tried Rational updater.

I've also searched for another tools on IBM partner page but there is only RAD (for WAS 4.x-7.x) and AST (for WAS 4.x-6.x - maximum Eclipse 3.2, I did not find anything for Eclipse 3.4)

I need tool (AST would be great, but I cannot find new version) based on Eclipse 3.4 to hot deploy EAR project into WAS running directly in eclipse (not remote debug)
 
Joseph Hayes
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WebSphere 7.0 actually comes with 2 licenses of IRAD (IBM Rational Application Developer) for this purpose rather than a separately packaged ASTK.
reference here: http://publib.boulder.ibm.com/infocenter/wasinfo/v7r0/index.jsp?topic=/com.ibm.websphere.nd.doc/info/ae/ae/catk_assemblytools.html
 
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper
Posts: 4968
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sweet post, greenhorn!

Welcome to the Ranch.

-Cameron McKenzie
 
Maciej Miklas
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
whare are all the WAS experts ?

 
Deepak Pant
Ranch Hand
Posts: 446
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The latest version of WebSphere Application Server Toolkit (AST) is 6.1.1.6. (Fixpack 6)

Visit following link to download the fixpack.
http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg24018784

The IBM WebSphere Application Server Toolkit V6.1.1.6 cumulative Fix Pack requires an IBM WebSphere Application Server Toolkit V6.1.1 install on either a Windows operating system.

The installation manager bundled with RAD or RSA will not upgrade AST. You can use the Rational Product Updater bundled with AST to upgrade to newer versions.

Until next time
 
Maciej Miklas
Ranch Hand
Posts: 61
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thank you!

This is how I've suspected it - It's based on Ecpilse 3.2.

Is there anything that is based on eclipse 3.4 ?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic