Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

New Entity Bean prevents JBoss AS to start

 
Peter Irmstadt
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!

I am using JBoss Seam on JBoss AS 4.2.1.GA.
I just added a new Entity to my project, and from this time on the JBoss AS doesn't start any more. The last log entry is about the ManyToMany relation I am using. The server stays at this position for minutes until Eclipse comes up with the message "JBoss Server couldn't be started in XX seconds" and it is shut down.

I put the server log here to not overflow this post.

This is the Entity I added:



I tried to change the datasource as well (from MySQL to HSQLDB) but that didn't change anything. When I am going to remove the new class everything works fine.

Do you have an idea what the problem might be?

Thank you in advance!
 
Alexander Curvers
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
im no expert but two things that i notice with my newbie eyes (but might be nothing wrong with it though) you use extra quotes in the table name and you do no initialize the artikelListe field at the declaration
in your log there no errors or warnings as far as i can see which is strange
 
Peter Irmstadt
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!

The quotes enable Hiberante to handle the table names case sensitive what it doesn't do by default.
The list doesn't need to be initialized (and besides doesn't seem to be related to my problem).

Thank you anyway

Any other ideas?
 
Alexander Curvers
Ranch Hand
Posts: 33
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i would try to simplify the class to narrow down the possible causes. Try removing the many to many relationship and try to run jboss, if it still doesnt run, remove some other features you might be the cause.. i guess using Integer instead of int doesnt make a diffrence..
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic