• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSP EL not evaluating  RSS feed

 
al nik
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm having problem in using EL like ${param.key} in my page. These are not evaluated.
I think it's because it goes in conflict with jQuery.
How can I solve this?
I tried with this but my EL are still not evaluated

thanks
 
Ulf Dittmer
Rancher
Posts: 42972
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is the relationship between a client-side tool like jQuery and a server-side technology like EL? What are you trying to do? Where -exactly- is it going wrong?
 
Eric Pascarello
author
Rancher
Posts: 15385
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do your EL evaluate with JQuery not even on the the page?

Eric
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66260
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is no conflict between EL and jQuery -- as pointed out, they don't even operate in the same sphere. Why would you come to this rather odd conclusion?

Your issue is most likely a mis-configuration of your web app. As such, I've moved this to the JSP forum for any further discussion (with appropriate title change).
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66260
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you looked through the JSP FAQ for help in solving this issue?
 
al nik
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your response.
Yes it should be a configuration issue.
Actually I don't know what I was thinking about when I placed that question...
The thing is that I remembered that once I had some client side problems with JSF EL and jQuery like mixed $# etc. I don't remember exactly what kind of issue..
The EL inside a JSTL is correctly evaluated, but something like ${param.buu} is not at it's printed out as plain text. As you said it should be a config issue, anyway I've never encountered it before.
sorry again for the 'odd' quest


 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66260
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What versions of JSP and JSTL are you using? Your problem frequently occurs when incorrect versions are mixed.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!