Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

How to set bootclasspath and extdirs attribute for javac

 
Vikram Gosain
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
Can anyone please tell me how to set the "bootclasspath" and "extdirs" attributes of javac ant task.?.


-Vikz
 
Martijn Verburg
author
Bartender
Posts: 3275
5
Eclipse IDE Java Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Vikram and welcome to Javaranch!

Have you taken a look at the online documentation?
 
Vikram Gosain
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Martijn Verburg wrote:Hi Vikram and welcome to Javaranch!

Have you taken a look at the online documentation?


Hello Martijn
I certainly tried my hand on this before asking this basic question...I did something like...


But I got exception....


So it made me apprehensive about my way of setting this parameter.
 
Martijn Verburg
author
Bartender
Posts: 3275
5
Eclipse IDE Java Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm the documentation isn't that clear is it , I would perhaps remove the toString call in that property replacement.
 
Vikram Gosain
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Martijn Verburg wrote:Hmm the documentation isn't that clear is it , I would perhaps remove the toString call in that property replacement.


If you mean to say is that we can use the path directly ,then I tried that option as well.I gave the path directly.What I tried is..

 
Martijn Verburg
author
Bartender
Posts: 3275
5
Eclipse IDE Java Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maybe, just maybe it doesn't like having the space character in the PATH, you could try installing Java @ C:\Java\<jdk version> and see if that makes a difference.
 
Vikram Gosain
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Martijn Verburg wrote:Maybe, just maybe it doesn't like having the space character in the PATH, you could try installing Java @ C:\Java\<jdk version> and see if that makes a difference.


Hello Martijn,I tried that as well.Did not work. Am I missing something.?.Or is my syntax wrong.??
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What do you have JAVA_HOME set to? It would appear you have it set to a JRE and not a JDK.
 
Vikram Gosain
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Peter Johnson wrote:What do you have JAVA_HOME set to? It would appear you have it set to a JRE and not a JDK.

Hi Peter.
I have tried with both JDK and JRE option.java home is actually set to point to jdk.


 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic