Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem in configuring Struts framework

 
S. M. Sabbir
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi ...
i m new to Struts and JEE.
I have configured my 1st application (HelloWorld) correctly through struts 2.
But when i run my project in web browser then the index.html of my project run properly.

Then after i click which should show, "Hello World" & current time & date is not showing.
Just showing a page writing


HTTP Status 404 - /life/revnx/HelloWorld.action

--------------------------------------------------------------------------------

type Status report

message /life/revnx/HelloWorld.action

description The requested resource (/life/revnx/HelloWorld.action) is not available.


--------------------------------------------------------------------------------

Apache Tomcat/5.5.27



So i am trying and trying but can't get appropriate result.

please help me.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's Struts, btw, not Sturts.

Either your application isn't deploying properly, or there's an error on startup. Both would be visible in the server log. Without any further information it's impossible to help.
 
S. M. Sabbir
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sorry for wrong spelling

any application deploying in my pc i am getting same thing like

"description The requested resource (/life/revnx/HelloWorld.action) is not available. "

I have set JAVA_HOME ,ANT_HOME ,CATALINA_HOME Path for java, apache-ant-1.7.0 & apache-tomcat-5.5.27.

I can't understand where the problem is..........
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
David Newton wrote:Either your application isn't deploying properly, or there's an error on startup. Both would be visible in the server log. Without any further information it's impossible to help.
 
S. M. Sabbir
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i got a lot of things there, & following information from the catalina.2009-06-04,




INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.5.0\bin;.;C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files\Java\jdk1.5.0\bin;C:\Program Files\Apache Software Foundation\apache-tomcat-5.5.27\apache-tomcat-5.5.27\bin
Jun 4, 2009 12:30:21 AM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jun 4, 2009 12:30:21 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 750 ms
Jun 4, 2009 12:30:21 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jun 4, 2009 12:30:21 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.27
Jun 4, 2009 12:30:21 AM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Jun 4, 2009 12:30:22 AM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jun 4, 2009 12:30:22 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Jun 4, 2009 12:30:22 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/31 config=null
Jun 4, 2009 12:30:22 AM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Jun 4, 2009 12:30:22 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 1469 ms
Jun 4, 2009 12:31:22 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive struts2-blank-2.0.14.war
Jun 4, 2009 12:31:23 AM com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
INFO: Parsing configuration file [struts-default.xml]
Jun 4, 2009 12:31:23 AM com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
INFO: Parsing configuration file [struts-plugin.xml]
Jun 4, 2009 12:31:23 AM com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register
INFO: Parsing configuration file [struts.xml]
Jun 4, 2009 12:31:23 AM org.apache.struts2.config.Settings getLocale
WARNING: Settings: Could not parse struts.locale setting, substituting default VM locale
Jun 4, 2009 12:31:24 AM com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory <clinit>
INFO: Setting DefaultObjectTypeDeterminer as default ...
Jun 4, 2009 12:38:28 AM org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:


catalina.2009-06-04



Jun 5, 2009 12:09:27 AM org.apache.coyote.http11.Http11BaseProtocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
Jun 5, 2009 12:09:28 AM org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
Jun 5, 2009 12:09:28 AM org.apache.catalina.core.ContainerBase stop
INFO: Container org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/struts2-blank-2.0.14].[jsp] has not been started
Jun 5, 2009 12:09:28 AM org.apache.catalina.core.ContainerBase stop
INFO: Container org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/struts2-blank-2.0.14].[default] has not been started
Jun 5, 2009 12:09:28 AM org.apache.catalina.startup.HostConfig undeployApps
WARNING: Error while removing context [/struts2-blank-2.0.14]
java.lang.NoClassDefFoundError: org/apache/struts2/util/ObjectFactoryDestroyable
at org.apache.struts2.dispatcher.Dispatcher.cleanup(Dispatcher.java:257)
at org.apache.struts2.dispatcher.FilterDispatcher.destroy(FilterDispatcher.java:225)
at org.apache.catalina.core.ApplicationFilterConfig.release(ApplicationFilterConfig.java:253)
at org.apache.catalina.core.StandardContext.filterStop(StandardContext.java:3670)
at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4354)
at org.apache.catalina.core.ContainerBase.removeChild(ContainerBase.java:893)
at org.apache.catalina.startup.HostConfig.undeployApps(HostConfig.java:1192)
at org.apache.catalina.startup.HostConfig.stop(HostConfig.java:1163)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:313)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
at org.apache.catalina.core.ContainerBase.stop(ContainerBase.java:1055)
at org.apache.catalina.core.ContainerBase.stop(ContainerBase.java:1067)
at org.apache.catalina.core.StandardEngine.stop(StandardEngine.java:448)
at org.apache.catalina.core.StandardService.stop(StandardService.java:510)
at org.apache.catalina.core.StandardServer.stop(StandardServer.java:734)
at org.apache.catalina.startup.Catalina.stop(Catalina.java:602)
at org.apache.catalina.startup.Catalina$CatalinaShutdownHook.run(Catalina.java:645)
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not sure how you could get that log message on startup.

I'm currently operating under the assumption your application isn't starting up: look for startup errors.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic