• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

j2ME package errors

 
Kenneth Blane
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

i just want to know why the following packages do not exist when i create a midlet:



are there alternative packages i could use??

Thank you
 
Tim Holloway
Saloon Keeper
Posts: 18367
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I would think that java.util.Properties would be found, but the others are all in JARs that aren't even part of the J2SE core install, much less J2ME.

Unfortunately, they're fairly complex, so you probably won't be able to just install and use them on a mobile system due to the limitations of the J2ME architecture. I don't know if there are any mobile equivalents or not, but just doing simple mail send or receive functions isn't too hard using basic socket code. The trouble comes when you want to support all the different MIME encodings and mailbox protocols.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic