• Post Reply Bookmark Topic Watch Topic
  • New Topic

Problems with security policies for Axis2 in Tomcat  RSS feed

Cedric Le Roux
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Using Debian 5, Tomcat 5.5, Axis2

I am seeing the following error when trying to run the Axis2 sample page at http://localhost:8180/axis2/axis2-web/HappyAxis.jsp

"There was a problem in Axis2 version service , may be the service not available or some thing has gone wrong. But this does not mean system is not working ! Try to upload some other service and check to see whether it is working."

I can get this error to go away if I disable Tomcat's security manager by setting

in /etc/default/tomcat5.5

I would like to avoid disabling the security manager so I have tried to add a .policy file for Axis2 in /etc/tomcat5.5/policy.d/

In theory this policy should grant all permissions for axis2 but I still get the error above, and I also see plenty of exceptions in Tomcat's log files.

Lastly, I found the following security policy which is supposed to allow Axis2 to run without granting all permissions. With this policy, I no longer see any exceptions but the error above still appears.

If you have any ideas as to how I can get Axis2 running properly with the security manager enabled I'd love to hear them.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!