Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

java.lang.NoClassDefFoundError: error when try to start websphere server  RSS feed

 
priya pillai
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi friends,
I installed WSApplication server 6.When I try to start the server using eclipse i am getting error of

java.lang.NoClassDefFoundError: Files/IBM/WebSphere/AppServer/java/jre/lib/ext/ibmorb/jar;C:/Program
Caused by: java.lang.ClassNotFoundException: Files.IBM.WebSphere.AppServer.java.jre.lib.ext.ibmorb.jar;C:.Program
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Exception in thread "main"


When I googled i found the soluton to this is

The "telling" thing about this error message is the fact that the text immediately after the NoClassDefFoundError is "Files/IBM/". This looks like you have a space in your classpath (i.e., "C:\Program Files\...")

You probably need to surround the directories that have a space in the name with double quotes.

In my case also i have one space between
java.lang.NoClassDefFoundError: Files/IBM/WebSphere/AppServer/java/jre/lib/ext/ibmorb/jar;

If the space is the problem how to remove the space....or sapce is not the problem then how to resolve this?

Please help

Thanks in advance

Regards
Priya
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!