This week's book giveaway is in the Agile and Other Processes forum.
We're giving away four copies of Real-World Software Development: A Project-Driven Guide to Fundamentals in Java and have Dr. Raoul-Gabriel Urma & Richard Warburton on-line!
See this thread for details.
Win a flower (🌹) or copy of Real-World Software Development: A Project-Driven Guide to Fundamentals in Java (📚) this week in the Agile and Other Processes forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Liutauras Vilda
  • Knute Snortum
  • Bear Bibeault
master stewards:
  • Devaka Cooray
  • Jeanne Boyarsky
  • Junilu Lacar
garden masters:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • salvin francis
gardeners:
  • Tim Holloway
  • Piet Souris
  • Frits Walraven

org/springframework/web/servlet/DispatcherServlet (Unsupported major.minor version 49)

 
pioneer
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
--------------------------------------------------------------------------------

Hi Experts,

I was working on a Spring web application using annotations with jdk 1.5. I later came to know that we are deploying this on WAS6.0 , which only supports JDK1.4. I changed my complete code to get rid of annotations.

Though the error I am getting is quite self explanatory, but I dont know hwo to get rid of it. I already compiled my web project as 1.4. is there any jar files I need to include or something like that?

Now today when I deployed my code on WAS6.0, I got the following error:

 
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you using a version of Spring (and its dependencies) that are suitable for use under 1.4?
 
Aman Singh
pioneer
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi David,

I didnt change or put any new dependencies. do I need to add any new jars ?
 
David Newton
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You're almost certainly using jars compiled for 1.5--that won't work.
 
Aman Singh
pioneer
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks David, will replace all the jars.

 
Eliminate 95% of the weeds in your lawn by mowing 3 inches or higher. Then plant tiny ads:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!